Dominos.com ordering issue.
Incident Report for nusutus+ Services Status
Resolved
This incident has been resolved.
Posted Dec 09, 2022 - 19:45 EST
Update
We are currently engaged with Domino's network operations center. and have found a solution to the issue. We expect to see this issue resolve momentarily
Posted Dec 09, 2022 - 19:37 EST
Investigating
Agents are unable to log into the dominos.com site to create orders. Ping Agents are still able to take calls but will be transferring orders to store during this time.
Posted Dec 09, 2022 - 18:05 EST
This incident affected: Ping Agent.