support@nusutus.com - spurious email rejected notice
Incident Report for nusutus+ Services Status
Resolved
The issue has been identified and resolved. Inbound emails to support@nusutus.com will no longer encounter bounce-back messages. We appreciate your patience during this time.
Posted Nov 17, 2023 - 12:30 EST
Monitoring
The issue has been identified and resolved. Inbound emails to support@nusutus.com should no longer encounter bounce-back messages. We are actively monitoring the situation for any further developments.
Posted Nov 16, 2023 - 17:00 EST
Identified
We have identified a disruption in our email infrastructure that is causing emails to support@nusutus.com to receive a reply with the error message "recipient's email server rejected." We are successfully receiving the emails and creating tickets however, inbound email may get this response.

Impact on Service: None

What We Are Doing:
We are conducting an investigation to pinpoint the root cause between our email cyber security provider and our ticketing system.

Timeline for Resolution:
The timeline for resolution is under assessment. This notice will be updated when an ETR (estimated time of repair) is available.
Posted Nov 16, 2023 - 13:59 EST
This incident affected: Customer Care.