Fleet Manager system maintenance underway

Incident Report for nusutusplus Services Status

Resolved

Maintenance is completed.
Users may need to reset and update their passwords.
Posted Aug 28, 2025 - 11:25 EDT

Update

Ongoing maintenance - manual access for Fleet Manager is up as of this morning.
Posted Aug 27, 2025 - 07:07 EDT

Update

Service maintenance is underway.
Posted Aug 26, 2025 - 15:00 EDT

Investigating

Maintenance underway
Posted Aug 25, 2025 - 17:27 EDT
This incident affected: Fleet Manager.