Google Cloud Platform outage

Incident Report for nusutusplus Services Status

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:32 EDT

Update

The underlying Google related outage should now be resolved and services are resuming
Posted Jun 12, 2025 - 17:09 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 17:08 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 16:29 EDT

Update

Google Cloud Services are reporting as being actively restored.
Fleet Manager service is restored.
The Live Agent service outage is still under investigation.
Posted Jun 12, 2025 - 16:18 EDT

Identified

Google is reporting that their engineers continue to work to restore services.
Posted Jun 12, 2025 - 16:08 EDT

Investigating

We are currently waiting on a update with Google services as they reporting an outage globally. This is affecting services related to Live Agent, Customer Support and Fleet Manager.
Posted Jun 12, 2025 - 14:47 EDT
This incident affected: Customer Care, Live Agent, and Fleet Manager.