Dominos ordering issues
Incident Report for nusutus+ Services Status
Resolved
This incident has been resolved.
Posted Nov 01, 2021 - 16:45 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 01, 2021 - 16:45 EDT
Update
We are continuing to investigate this issue.
Posted Nov 01, 2021 - 16:45 EDT
Update
We continue to investigate the issue with Domino's Corporate.
Posted Nov 01, 2021 - 16:12 EDT
Investigating
Our PING Agents are seeing issues placing orders on the Domino's website. Calls are currently being routed to stores until this issue is resolved.
Posted Nov 01, 2021 - 14:06 EDT
This incident affected: Ping Agent.