Service interruption - Call Quality issues for some regions and callers using NuSutus VoIP
Incident Report for nusutus+ Services Status
Resolved
This incident has been resolved and all services are back to normal at this time.
Posted Jan 30, 2024 - 18:24 EST
Monitoring
The upstream data centers are reporting network stability and reports that call quality has been restored to all impacted users. We're actively monitoring the situation.
Posted Jan 30, 2024 - 17:08 EST
Identified
The root cause has been identified as an issue with an upstream data center. They're actively engaged and working towards resolution.
Posted Jan 30, 2024 - 16:14 EST
Investigating
Please note that we are aware of an upstream carrier experiencing degraded call quality and performance. Some stores may experience call quality issues on inbound calls. This issue is under investigation.
Posted Jan 30, 2024 - 15:03 EST
This incident affected: Ping Telecom (Inbound Calling).