Credit Card Payments not available
Incident Report for nusutus+ Services Status
Resolved
Please note that credit card payments are working as expected.
Posted May 02, 2022 - 12:57 EDT
Investigating
Credit card payments are currently unavailable for Ping Agent. Calls may be transferred to the store for payment capture should the customer require it.

We have engaged with our engineering team and hope to have this resolved ASAP.
Posted May 02, 2022 - 12:53 EDT
This incident affected: Ping Agent.