High Call volume resulting in longer than expected hold times
Incident Report for nusutus+ Services Status
Resolved
Ping Agent caller wait times have been restored to ideal levels. Callers to the service are no longer experiencing extended delays reaching agents to place an order.
Posted Nov 02, 2023 - 20:07 EDT
Monitoring
This afternoon, Ping Agent saw a larger than expected spike in call volume that extended call answer times. Additional staff has been brought in and we expect service levels to return to normal shortly. We are also investigating the cause behind the unexpected volume increase.

Thank you for your patience.
Posted Nov 02, 2023 - 18:55 EDT
This incident affected: Ping Agent.