Credit Card Payments - Technical Issue
Incident Report for nusutus+ Services Status
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 14:16 EDT
Monitoring
A fix has been implemented and we are monitoring.
Posted Sep 09, 2022 - 14:10 EDT
Identified
The issue has been identified and the team is working on a resolution.
Posted Sep 09, 2022 - 13:55 EDT
Update
We have engaged our development team and are investigating.
Posted Sep 09, 2022 - 13:25 EDT
Investigating
We are currently experiencing an issue with credit card validation. As we investigate this issue customers requesting to use a credit card may be transfered to store.
Posted Sep 09, 2022 - 13:06 EDT
This incident affected: Ping Agent.